1999 trooper speaker problem

Use this forum to discuss audio and electronic upgrades for your Isuzu

Moderator: Staff

1999 trooper speaker problem

Postby TODhater » Wed Apr 05, 2017 6:13 pm

So I thought I would be cool and throw some pioneers in all four speaker locations of my trooper. While doing the rear set I was comparing and contrasting with the factory speakers and poof everything went dead. I was told something might have touched ground but it all looks good to me. Anyone ever come across an issue like this?
TODhater
Drives on Dirt
 
Posts: 58
Joined: Thu Apr 21, 2016 6:13 pm
Location: Taunton ma
Has thanked: 15 times
Have thanks: 3 times

Sponsor
 

Re: 1999 trooper speaker problem

Postby Georgia159.com » Wed Apr 05, 2017 7:01 pm

Does radio come on at all (light up)?
199? Rodeo (ISO of my next project truck- being picky)
1997 Rodeo 2WD 3.2 V6 Auto (4-1-13 - Purchased for $580. Best deal ever. My DD.)
1994 Rodeo LS 2WD 3.2 V6 Auto (2015 - Bought for Parts, but still running! The Backup.)
1997 Honda Passport 2WD 3.2 V6 Auto (2015 - Parts donor - PM if you need something)
Georgia159.com
Loyal P'up
 
Posts: 144
Joined: Wed Apr 10, 2013 10:26 pm
Location: Middle Georgia
Has thanked: 17 times
Have thanks: 4 times

Re: 1999 trooper speaker problem

Postby TODhater » Wed Apr 05, 2017 7:09 pm

Radio is working fine. It even shows when a station is in stereo. Just nothing coming out of the speakers. Maybe some kind of protection mode?
TODhater
Drives on Dirt
 
Posts: 58
Joined: Thu Apr 21, 2016 6:13 pm
Location: Taunton ma
Has thanked: 15 times
Have thanks: 3 times

Re: 1999 trooper speaker problem

Postby Georgia159.com » Wed Apr 05, 2017 7:58 pm

TODhater wrote:Radio is working fine. It even shows when a station is in stereo. Just nothing coming out of the speakers. Maybe some kind of protection mode?


My stereo installer prior life speaking here...
Make sure the mute button is OFF. (Happened all the time! :wink: )

Next, is there any kind of amplifier? Aftermarket or Factory?
If so, could have popped a fuse on the amp I supposed.

Some amps do have protection mode but it should go back to normal when the short circuit is gone.

What kind of head unit (radio) are we talking about? Factory or some kind of aftermarket?
199? Rodeo (ISO of my next project truck- being picky)
1997 Rodeo 2WD 3.2 V6 Auto (4-1-13 - Purchased for $580. Best deal ever. My DD.)
1994 Rodeo LS 2WD 3.2 V6 Auto (2015 - Bought for Parts, but still running! The Backup.)
1997 Honda Passport 2WD 3.2 V6 Auto (2015 - Parts donor - PM if you need something)
Georgia159.com
Loyal P'up
 
Posts: 144
Joined: Wed Apr 10, 2013 10:26 pm
Location: Middle Georgia
Has thanked: 17 times
Have thanks: 4 times

Re: 1999 trooper speaker problem

Postby TODhater » Wed Apr 05, 2017 8:15 pm

Stock radio, stock speakers. I checked for the mute button, no such luck (I wish it was just that!)
TODhater
Drives on Dirt
 
Posts: 58
Joined: Thu Apr 21, 2016 6:13 pm
Location: Taunton ma
Has thanked: 15 times
Have thanks: 3 times

Re: 1999 trooper speaker problem

Postby Georgia159.com » Wed Apr 05, 2017 9:37 pm

Ok, we are talking about a factory radio that is 18+ years old... Hate to say it, you may have fried the internal amplifier in the radio that drives the speaker. A brief short circuit probably popped something inside the unit... Head units are cheap these days, so just get a new one.

Just my best guess. (I was in the car stereo business in the late 80s/early 90s, for what it's worth...) LOL
199? Rodeo (ISO of my next project truck- being picky)
1997 Rodeo 2WD 3.2 V6 Auto (4-1-13 - Purchased for $580. Best deal ever. My DD.)
1994 Rodeo LS 2WD 3.2 V6 Auto (2015 - Bought for Parts, but still running! The Backup.)
1997 Honda Passport 2WD 3.2 V6 Auto (2015 - Parts donor - PM if you need something)
Georgia159.com
Loyal P'up
 
Posts: 144
Joined: Wed Apr 10, 2013 10:26 pm
Location: Middle Georgia
Has thanked: 17 times
Have thanks: 4 times

Re: 1999 trooper speaker problem

Postby TODhater » Thu Apr 06, 2017 7:22 am

Yes thank you. I'm planning on getting a new head unit. I just want to make sure that the speakers will function with a new one
TODhater
Drives on Dirt
 
Posts: 58
Joined: Thu Apr 21, 2016 6:13 pm
Location: Taunton ma
Has thanked: 15 times
Have thanks: 3 times


Return to Audio & Electronics

Who is online

Users browsing this forum: No registered users and 1 guest